[Solved] Dark mode not working

Home Forums Support [Solved] Dark mode not working

This topic contains 6 replies, has 2 voices, and was last updated by  BiGilSoft 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #906 Reply

    Mike

    Hi,

    I have just downloaded & installed the free version 3.0.6 to try before buying but the dark mode is not working correctly.
    On any window when I select “Set Dark” the window will flash black for a very short time and then revert back to it’s original colours.

    I am on Windows 10 1709

    Thanks,
    Mike

    • This topic was modified 1 month, 1 week ago by  BiGilSoft.
    • This topic was modified 1 month ago by  BiGilSoft.
    #950 Reply

    BiGilSoft
    Keymaster

    Hello, previous reply deleted because it did not answer the problem you have.

    I forgot about the known dedicated graphics, not primary graphic card bug.
    It was previously reported and also found by me while I developed it back in the days. but I forgot about it and sorry for not providing you the solution.

    If you have NVIDIA / AMD graphics card in addition to the INTEL graphic card, you should setup in your system that WindowTop.exe and WindowTopHelper.exe will not run with the dedicated graphics card and will run on the integrated graphics card.
    It must run on the integrated graphics card. otherwise it will not work.

    Follow the following steps and do it for WindowTop.exe and WindowTopHelper.exe
    (WindowTopHelper.exe located in C:\Program Files\WindowTop\WindowTopPro )

    Before you begin, close WindowTop and after you done, open the program again.
    The steps are similar for AMD

    DO THE SAME STEPS FOR WindowTopHelper.exe

    Let us know if it solved your problem.

    • This reply was modified 1 month, 1 week ago by  BiGilSoft.
    • This reply was modified 1 month, 1 week ago by  BiGilSoft.
    • This reply was modified 1 month ago by  BiGilSoft.
    #954 Reply

    Ruben

    hello, according to your indications I have not been successful to activate the night mode. Now every time I activate the dark mode the black screen stays completely. I do not know what can interfere so that it works correctly

    #958 Reply

    BiGilSoft
    Keymaster

    Did you follow these steps?
    This bug is known and reported and it should be solved for you if you follow these steps. A costumer reported about this and after he did these steps it solved for him.

    Please try the following steps:
    1) Close WindowTop – right click on the WindowTop tray icon and then click “Exit”

    2) Go to:
    C:\Program Files\WindowTop

    And do the following:

    Let me know if you have this “integrated graphics” option.

    3) Make sure that dark mode pro is disabled

    4) Enable dark mode for some window and let me know if you still see black window issue.

    If not then we have a progress,
    please update.

    #961 Reply

    BiGilSoft
    Keymaster

    In addition – desktop composition must be enabled!
    It can be disabled in Windows Vista and Windows 7. But not from Windows 8 and above.

    There is no way it can work without desktop composition. It is based on this.
    If this is your case (You probably using Windows 7 or Vista) then you must enable it back to make it work.

    If you don’t know how to enable it back, follow this video:

    #963 Reply

    Mike

    Hi BiGilSoft,

    My laptop does have integrated and a separate Nvida graphics and following your instructions to make WindowTop use the integrated graphics has made dark mode work for me.

    Thanks,
    Mike

    #965 Reply

    BiGilSoft
    Keymaster

    Glad to hear.
    This is no surprise. This is the solution to the problem.
    For those that it did not work for them, make sure that desktop composition is enabled (You probably have Windows 7).
    See post http://windowtop.info/forums/topic/dark-mode-not-working/#post-961

    My guess is that dwm.exe (what makes desktop composition) is running on the integrated graphics and the software must run on the graphics card that render the desktop composition / dwm.exe …

    I found on NVIDIA forums someone that probably confirms it. He asked how he can force that it will render on the NVIDIA card.. it probably would be better if dwm.exe was run on the detected graphics processor because maybe the dark mode effect was work faster.. but I did not found that someone was managed to do this.

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: [Solved] Dark mode not working
Your information: